UrBackup is an easy to setup Open Source client/server backup system, that through a combination of image and file backups accomplishes both data safety and a fast restoration time.
UrBackup is an easy to setup Open Source client/server backup system, that through a combination of image and file backups accomplishes both data safety and a fast restoration time.
File and image backups are made while the system is running without interrupting current processes.
UrBackup also continuously watches folders you want backed up in order to quickly find differences to previous backups. Because of that, incremental file backups are really fast.
Your files can be restored through the web interface, via the client or the Windows Explorer while the backups of drive volumes can be restored with a bootable USB-Stick (bare metal restore).
A web interface makes setting up your own backup server really easy. For a quick impression please look at the screenshots here.
Currently there are over 21,000 running UrBackup server instances (with auto-update enabled) with some instances having hundreds of active clients.
Only copy hash potion of old chunkhash file on failure. This fixes incremental partial backup failures when downloading a script with indeterminate size is interrupted
Fix issue with too small sparse extents causing patch failures
Prevent ignoring permissions when restoring files via tokens (reported by Valentino Paulon)
Add optional proof of work DoS mitigation to Internet authentication
Limit max PBKDF2 iterations performed on server fixing a DoS issue (reported by Matheus)
Timeout connection after 30s in initial state when authenticating Internet connections fixing a DoS issue (reported by Andrew Elmore)
Add settings to allow a client to restore all clients and a setting to disable client rename detection
Reset allow_restore_clients when updating virtual clients if necessary, making the server setting allowing all clients to restore apply without server restart
Don’t take image backup interval into account when image backups are disabled
Improve error handling when hashing patch
Only startup one virtual client at a time, not all at the same time
Remove hash threads beta setting
Add setting to limit max number of simultaneous backups per client group
Increase send MBR connect timeout fixing issue when this takes longer than 10s